Textastic is a text, code and markup editor for iPad and iPhone with rich support for syntax highlighting, FTP, SFTP and Dropbox. It will continue to be actively developed to provide you with the features you need to get your work done.

In order to achieve this, we would appreciate any and all feedback on challenges encountered when using Textastic.


Please also have a look at the manual.


Be sure to vote for the features you want to see implemented!
0
Not a bug

Cannot download after first file

Ken Allen 4 years ago in iPad • updated by Alexander Blach (Developer) 4 years ago 2
Defined the FTP connection to my web site and was able to download, edit and upload one file, but now when I open the FTP connection it shows the list of files, but selecting one does not enable the Download option! I have tried several times, even quitting the app and launching it again. 
0

Really great app, I'll buy it today

Zsolt Stelkovics 6 years ago • updated by Alexander Blach (Developer) 6 years ago 1
It looks really the best code editor on the appstore, and it's so cool that you reflect for the comments, askes, keep up the good work!
0

instable when using reasonable sized files

Sebastian Konietzny 6 years ago • updated by Alexander Blach (Developer) 6 years ago 7
the app crashes when using files of a size of 5 mb! that's not acceptable as this size should be no problem at all!
0

Latex syntax highlighting incomplete

Rav Online 6 years ago • updated 6 years ago 2
Just got the app and noticed a problem with the highlighting of Latex syntax. While % and \ works, math formulas within $ brackets are not highlighted.

Hopefully this can be fixed before the next update.
0
Under review

Problem with iPad Pro

Bob Lewis 2 years ago in iPad • updated by Tahin Syed 6 months ago 4

While the app works beautifully on the iPad Air, it does not perform equally on the iPad Pro.

When I attempt to "Open" a file that resides in a cloud drive (Google, One Drive, etc.), I get an error message: "Failed to launch 'Google Drive' The document picker 'Google Drive' failed to launch (0)."


This same error message pops up regardless of the drive or app I attempt to access.


I can select a file from my Google Drive app and "Open in" Textastic successfully, but can't "Open" from the drive.

0
Under review

bug report: using wireless keyboard, pressing up many times beyond top of document appears to maintain weird state

Danny Yoo 6 years ago • updated by Alexander Blach (Developer) 6 years ago 0
How to reproduce. Create a JS file. First line should be:

// hello world this is a test

and the second line should be

// this is only a test

Position the cursor on the word "world". Press the Up key three times. Now press Down. Note that the cursor stays on the first line. Also note that if you press the Down key exactly three more times, it takes on the third time.

I'm using the apple wireless keyboard to see this. This bug does not appear to affect the virtual keyboard.
Answer
Thanks, I'll try to reproduce it.
0

Fix highlighting for t-sql CREATE PROCEDURE/CREATE PROC syntax

Андрей Татарников 6 years ago • updated by Alexander Blach (Developer) 6 years ago 1
Highlighting for T-SQL "CREATE TYPE" works fine, but for "CREATE PROC" or "CREATE PROCEDURE" does not. 
0

Why does the Editor change file extensions?

Rolf Lochbühler 5 years ago in iPad • updated by Alexander Blach (Developer) 5 years ago 3

I have Dropbox sync a .bib (BibTeX) file, since I'd like to be able to edit it on various devices. I assume the proper workflow is to open the file in Textastic using the menu in the Dropbox app. But when I do so, Textastic creates a copy of the file and also renames it to .a4d. Is this behavior intended?

0

Moving a file seems to break its link to the FTP server.

Doug Lerner 6 years ago • updated by Alexander Blach (Developer) 6 years ago 1
0
Under review

Newline at EOF

jsageryd 4 years ago • updated 4 years ago 2
I would like a config option to always add a newline at EOF.