+1

Sftp Files not syncing

Dimitry Chamy 9 years ago updated by Alexander Blach (Developer) 8 years ago 7
I am connecting via sftp on ios5 iPad 2 and my file changes are not updating when I check them on my desktop client...
Started working again ... Wierd!

Today I was using Textastic at Starbucks. When using SFTP the uploading back to the server was failing more than half of the time. The overwrite popup would not appear. Or the file would try to upload and then the uploading popup would go away and you wouldn't know if it uploaded or not. I was getting SSH layer error messages sometimes. 


When I came home and had a better network connection, the uploading worked flawlessly. Maybe there is something wrong about handling network errors, that isn't being caught? Had to attempt multiple tmes to get some files uploaded back to the server.


I have not tried anything other than SFTP, I will test again tomorrow.

Did you use a Wi-fi connection at Starbucks or a cellular connection? Maybe they have a firewall in place?


Enabling the "Debug Log" setting in the connection's settings might help to find out what's going on.

I will enable debug log and submit more info tomorrow.

A firewall wouldn't be intermittent. After a couple tries, it finally goes through. Today is seems to be working without issues. May be the connection is better today. I'll send a report as soon as it happens again.

OK, it just failed an upload.... where is the debug log to send you?


I'm going to stop using Textastic until I can get the log to you.

The debug log is saved in the "logs" directory in Textastic.