0
Not a bug

On-screen keyboard covers bottom half of SSH in landscape mode

Gordon Smith 7 months ago in iPad updated by Alexander Blach (Developer) 7 months ago 5
My Textastic setup:

  Textastic beta version 9.8.6 (299)

  iPad Pro (12.9-inch ) (4th generation)

  iPadOS version 15.4.1.


In SSH sessions, text scrolls past the on-screen keyboard (additional keys row turned off) when the iPad is in landscape orientation.  This obscures the bottom half of my SSH sessions (including the prompt).  Portrait orientation works fine.


If I press the "hide keyboard" key to dismiss the on-screen keyboard, and then tap the screen to bring the keyboard back, scrolling accommodates the keyboard.


The problem occurs when connecting to my Linux computer...

  Xubuntu 20.04 LTS

  bash version 5.0.17(1)-release


...but not to my Mac...


  MacBook Pro 15-inch (2017)

  MacOS version 11.6

  bash version 5.1.16(1)-release

GOOD, I'M SATISFIED
Satisfaction mark by Gordon Smith 7 months ago
Under review

Thanks, I'll try to reproduce it. 

I tried to reproduce this on my iPad Pro (12.9-inch, 4th gen) connecting to Ubuntu 22.04 LTS, but it worked fine every time. I used landscape orientation, no external keyboard and had additional keys disabled.

Here is a screenshot of how this looks right after connecting:

Before I set up a new Xubuntu 20.04 VM, can you please send me a short screen recording video of the problem? Maybe I can see something.

Please also try if a reboot of your iPad changes anything. I have seen keyboard problems go away after a restart. 

+1

Thank you.  Rebooting the iPad fixed the problem.  I'm sorry that I didn't try that before submitting the bug report.

Not a bug

It's great to hear that it seems to work now. Let me know if it happens again.