Under review

ssh to server starting irb (Ruby) not working

rpf13 3 years ago in iPad updated by Alexander Blach (Developer) 3 years ago 5

I‘m connecting via ssh to a linux server which has ruby running on it. If i want to go into the IRB shell of ruby, textastic hangs, it just shows a „triangle“ and completely hangs, I have to kill the ssh session to get out. Why does IRB not work when using it in textastic? I cannot understand...

Under review

I just tried to connect to a Debian machine and started irb - for me it works as expected: I can run Ruby commands. 

Does it work when you connect to the same server with a different app? Can you cancel irb using Ctrl-C in Textastic?

did you check with Textastic on the iPad? I have just checked with Secure CRT on the iPad. Secure CRT is a very well known ssh terminal app. With that it works flawlessly. It‘s also not an issue on the ubuntu server running ruby, I have tried with several different ones. It works on Secure CRT on iPAd but also on any other PC, Mac, Linux connecting to the servers. Only Textastic shows me this „triangle“ and hangs. 

I am only talking about textastic on the iPad, I have never tried it with Textastic on other plattforms.


I tested it on my iPhone, but now I also tested it on my iPad running iOS 14.2 and Textastic 9.5. 

Here is a screenshot running the line "Dir.entries 'test'" in irb which lists all files in a subfolder called "test" on my server:

Thanks a lot for the feedback and the test. It gets even more interesting. I have tried with my synology nas server, which is local in my LAN. SSH, irb, works fine. Well, a very old ruby version 2.4.2 is installed, but I cannot imagine the version makes the trick.

When I go back to all the other servers, it does not work, as mentioned, this „blinking triangle“ appears, and the session is blocked. I have to mention that for this I always connect via IPSEC vpn  (the iPad embedded vpn service) to the remote location.

As mentioned before, with Secure CRT on iPad the same thing works flawlessly. I work on those servers everyday, usually from Mac. Now I wanted to setup the same thing with Textastic.

Any idea what could cause the issue or how to tshoot further?

It could be related to the VPN connection. Can you connect to a server on a local network and check if you are seeing the same problem? Of course I understand if that is not possible.