Under review

Syntax Bundle Not Loading (javascript-react.tmbundle)

akbuck667 4 years ago in iPad updated by Alexander Blach (Developer) 4 years ago 1

I was following the manual on adding .tmbundle files for custom syntax highlighting, however, one bundle I tried to install isn’t loading into the application. Are there any methods or steps for users like me to debug this? I tried enabling the debug logs, but it looks like only the successful loading of bundles are logged when performing the “Reload Customizations” action.

The bundle in question is: https://github.com/jjeising/javascript-jsx.tmbundle


- I did find this bundle through online search- but based on my understanding, this bundle should be supported by Textastic.
- I am also assuming that there are currently no issues with this bundle. If there is, then I would expect to be able to see an error in Textastic’s debug logs.

- I have configured other syntax bundles in the application on the same device (at the same time as well), so there is no inaccuracy with my #Textastic directory.

Under review

This seems to be a JSX syntax definition for TextMate 2 which injects itself into the built-in JavaScript syntax.

Textastic only supports TextMate 1 (and Sublime Text 2) syntax definitions, which do not support injection.