0
Under review

Using .sublime-syntax files with 7.0

ninjasong 1 year ago in iPad updated 1 year ago 6

From the release notes:


• Compatible with TextMate and Sublime Text 3 syntax definitions and themes 

I've tried dropping my .sublime-syntax file into the #Textastic folder, but I'm not getting the option to use it. It works fine on Sublime.

Under review

You need to put the sublime package folder into the Local Files/#Textastic folder and it should work. So, if you create a folder in #Textastic and then put your .sublime-syntax file in there, it should work. Just make sure that the folder does not end in ".tmbundle" since this is reserved for TextMate bundles.

Thanks for the feedback, but I'm still having trouble enabling it.


So, the custom syntax I created is just a .sublime-syntax file, in YAML. I don't have a "Sublime Package folder"


In my Local files i've tried the following:


#Textastic/tcm.sublime-syntax

#Textastic/tcm/tcm.sublime-syntax

#Textastic/tcm/Syntaxes/tcm.sublime-syntax


None of these folder structures work to enable my custom syntax.


The second and third folder structure should work. Can you please send me the file so I can try to reproduce it on my device?

I see - here is my file: https://www.dropbox.com/s/h7o9zntgaridjf5/tcm-notes.sublime-syntax?dl=0


In case you're wondering, I'm a web developer who is now studying Traditional Chinese Medicine. I've been using my code editor to take notes, and have developed this syntax definition for rich note taking.

It works for me: I put the file into Local Files/#Textastic/tcm/. Then I quit Textastic using the multi-tasking switcher and restarted it. I could then open a file, go to the File Properties and select "TCM-notes" as the syntax definition.


However I would need to have an example file to see if the syntax definition works as intended.

Hi Alex! Thank you - everything works swimmingly. I thought I had tried restarting Textastic, but perhaps I didn't do it with the correct folder structure. 


It's all working great. Thanks so much.