Under review

Memory issues in IOS 11

Ted Bahas 7 years ago in iPad updated by Anthony Taylor 6 years ago 21

I am using  CSV and .DB files in this version and it is getting stuck on basic copy and paste functions. If I select all it took more than 30 sec to make the selection. During this time the program was unresponsive. This is stuff that worked very quickly in earlier versions. I am using this with latest iPad 10.5 and running OSX 11

Under review

I have seen such problems with the clipboard on iOS 11. It seems to be related to the feature called Universal Clipboard that allows you to copy and paste across Mac and iOS devices. See https://support.apple.com/kb/PH25168?viewlocale=en_AP&locale=en_AP for details.

It seems to happen when iOS tries to determine if it should show the Paste command and a Mac is nearby.

Awesome response time Alexander. I will try that out and see if it fixes it. I really love the app. I use it almost every day to replace what I have been doing in BBEdit. Its great not to be tied to the laptop anymore

I turned off handoff completely and it still has issues. Same sluggish response. I also have restarted the iPad, Deleted and re-downloaded the app and closed all the other apps and I am still getting the same issues.

Ok, so it looks like it is a different problem you are seeing. Can you maybe send me a file in which you see these problems so I can try to reproduce it on my iPad? You can send it to support@textasticapp.com.

Oh, and please also tell me what exactly I need to do to trigger the problem.

Sure thing. Its on the way

I opened the file you sent me on my iPad 10.5 running iOS 11, did two single taps on the editor and chose "Select All". I do not see any delay at all. I also tried copying and pasting and see no delay.

Maybe it is related to other settings in the app. Which syntax definition and theme do you have selected? Which keyboard are you using? Which font and size?

The font is Menlo 15pt  and the theme is Eiffel and I am using the dark keyboard setting. Which theme are you using to test it? I will set mine to that and see if it makes a difference. Thanks!

One other thing that I failed to mention is that I am using the Keyboard to select all.

I don't know where to find a "Select All" command on the keyboard. Do you mean with a two finger gesture?

I've set the same font and theme and see no difference, sorry. I'm using the "Plain Text" syntax definition.

Or do you mean a hardware keyboard? I just tried to select text with my Apple Magic Keyboard connected over bluetooth: no problems.

What happens if you copy the same text into Apple's Notes app and try to select text there? Do you see similar issues?

Using command A on the keyboard. I see now that it is not listed among the commands. It has worked before with IOS 10

I just tried with the tap and it still hung up.

I had it send you a crash report.

Selecting the same amount of text in the notes app has no issues. It selects right away

Any word on this ? It still crashes every time I try to execute copy and past function. None of my other text editor apps are exhibiting this problem. I also upgraded to IOS 11.0.1 and it exhibits the same behavior.

Sorry, but it's hard for me to help if I cannot reproduce the problem on my own device.

If you disable bluetooth in the Settings app, does the problem still occur when you select all text?

Can you maybe make a short video that shows the problem and upload it to Dropbox or a similar service so I can see exactly what is happening? 

I will send you a video I just made.

Thanks! That really helped. I could now reproduce the problem. The difference is that I did a single tap on the editor to bring up the on-screen keyboard before using "Select All".

If I do a double tap instead to select text without bringing up the on-screen keyboard and use "Select All", I can see the problem you are seeing.

I'm going to try to fix it!

Fantastic! I have come to really rely on this program. I do quite a bit of coding on the road and I hate going back to the Laptop. Freedom!

Can you please check if the following fixes the issue for you:

- open the Settings app

- go to General -> Accessibility -> Speech

- disable "Speak Selection"

If I disable this setting on my device, the problem seems to go away.