Unable to open Working Copy folders in Textastic

Ara Adkins 7 years ago in iPhone updated by EFlynn 6 years ago 16

The combination of the latest Textastic version (6.4, iOS) and the latest update to Working Copy (3.1.0) it is now impossible to pick folders for inclusion at the top level on iPhone. While it is possible to drag and drop on the iPad, there is no equivalent solution for iPhone.

It's a big workflow damper for making broader changes across repos as the picker in Files can be quite slow in larger repositories (not that this is your issue). 


A prompt and helpful response! I love Textastic. 

Satisfaction mark by Ara Adkins 7 years ago

Yes, we currently do not have a solution to open folders from Working Copy in Textastic on iPhone. In one of the betas it was possible to select a folder in the document picker, but they removed that feature. We hope that Apple adds it back in an iOS 11 point release.

I hope that some solution can be found! It’s pretty workflow-breaking at the moment due to the slowness of the Working Copy document picker extension. 

We received a hint from Apple and I added a workaround in Textastic 6.4.1 to open folders on iPhone: 

  • in Textastic, tap "Open…" 
  • navigate to Working Copy 
  • press "Select" in the top toolbar 
  • select a folder  
  • tap "Open" 

Please only use this to open folders from Working Copy. If you try to open other folders - like for example from iCloud Drive, bad things can happen :)

That's working perfectly! Thank you so much for getting onto this so quickly, I really appreciate it. 

It seems that the workaround isn't working anymore. There is no "select" field, only "cancel" is shown. On my IPad the select field is there and it works fine.

It seems like the Select button isn't shown sometimes. In that case tap Cancel and then tap Open... again. Looks like an iOS bug. 

Thanks for your fast reply!
I tried several times but it never worked. I'm on iOS 11.4 by the way. Hopefully Apple changes this behavior.

Hey Alex,

A friend of mine showed me that the document picker on an other app (Kodex) is able to open folders.

It works great for me on iOS 11.4.1 with Textastic 7.0.3 on my iPhone X. Here is a screenshot.

 I don't know why the select button doesn't appear for you, sorry.

That's strange, 

I will try it with 11.4.1 I'm still on 11.4. 

will post the result later.

Thanks for your fast replies. Your support is really great!

Ok, it's working now. The update and a restart did the job. 

Thanks for your efforts. 

Great to hear that it works now!

Dear Alex,

I’m trying to open Working Copy from Textastic on my ipad, but as you can see from the attached screenshots, Working Copy is not one of the options. Can you help please? Thanks. Errol

Hello, go to the "Files" app. There you can tap on the Locations > "Edit" button and add Working Copy.

You can also use Drag and Drop to drag a repository from Working Copy into Textastic. 

I'm currently working on a new manual where this is explained in detail. You can find a preview of the manual here: https://www.textasticapp.com/v7/manual/integration_other_apps/git_client_working_copy.html

Works perfectly now! Textastic is fantastic, and is getting better all the time. Thanks for your hard work Alex and for answering my question. EFlynn