0
Under review

Error after opening file with ownCloud

Andreas Neumann 5 years ago in iPad updated by Alexander Blach (Developer) 4 years ago 7
Every time I open a file via ownCloud, change something and then stop editing, I get an error "der Vorgang konnte nicht abgeschlossen werden (Cocoa Fehler 4). But when I switch to the owncloud-app I see, that the file gets uploaded.
Could you have a look into this, please?
Great app anyway!

Under review
I assume you are using the "Open…" command in Textastic to open the file from ownCloud. Does the same happen when you try to open and save such a file with another editor that supports the document picker like Byword?

I do not have an ownCloud server myself.
I installed and tried Byword yesterday, but the error did not appear. I can give you access to an ownCloud-installation, if you need it for testing?
Yes, please. You can send it by email to support@textasticapp.com

A step-by-step guide about how to reproduce the issue would be nice.

I could reproduce the error with the ownCloud Demo installation at https://demo.owncloud.org/


I do get the errors you describe in Textastic and I also tried it with Byword. When using Byword, I get the same error messages on the debug console. The only difference is that Byword doesn't present the errors to the user while Textastic does. You can check this for yourself with the "iOS Console" Mac app http://lemonjar.com/iosconsole/


So, this really looks like a bug in the ownCloud file provider extension. I have debugged everything related to saving and can't find a problem in Textastic's code.

Dear Alexander,


just to let you know: I have the same problem. This happens not only with owncloud, but with other document picker enabled apps too, like e.g "working copy".

With Textastic I get errors like "...konnte nicht nach file12345566676754320 bewegt werden, da letzteres nicht existiert, oder der Ordner nicht existiert."


With Byword it works fine. So it looks like a problem with the temporary file names.


Btw. Thanks for your good work! Apart from this error Textastic is an excellent App!


Best regards

Sven

That's weird. I'm using Apple's UIDocument class which handles saving automatically and is also responsible for the temporary files names you are seeing. Does a reboot of your iPad fix any of the problems you are seeing? Unfortunately, I have seen many document picker issues go away after a reboot...

Thanks for your Feedback. I am afraid, reboot does not help. I deleted and re-installed Textastic, then I deleted and re-installed Owncloud, and then I wiped the iPad and did a clean install. I have absolutely no idea what to try next.