Under review

Transfer error login denied

carlos beukes 11 years ago in iPad updated by jmbenedetto 3 years ago 6

Hi -

I keep getting this error: 'Transfer error login denied'

Login details work fine in cyber duck, transmit etc on my mac so I do not believe problem is with login details.

Have tried different settings: active/passive...

I am worried that this app might not be for me. Would a refund be in order?

I'm willing to try a little more but at some point soon need to try another FTP app in the hopes it might work for me.

I heard good things about this app so I thought I'd just go straight ahead with purchasing it. I am not really knowledgable enough to use this app perhaps. I develop websites and never have problems with FTP related matters. This app has got me confused and a little disappointed.

Would be great to hear back from someone soon.

Thank you kindly,


Please try to enable the "Debug Log" setting in the connection's settings screen. Tap on the blue arrow on the right side of a connection to change its settings. This creates a log file when you try to connect to the server which might help you find out what's wrong.

Same problem for me. Debug doesn't do anything since I can't even connect in the first place. Isn't DEBUG meant to log bugs in the LOGS directory on the connected server? Wouldn't that imply that I need to be connected? I can't connect, and I've tried every setting. $8 wasted? I'll be looking for a refund as well if this thing isn't going to do what it is advertised to do. Thanks for your support.
Under review
The "Debug Log" setting logs client-side connections details including server answers and error codes. The log file is saved in Textastic under "Local Files" in the "logs" directory.

If you do indeed get a "login denied" error as this feedback topic suggests, then it means almost certainly that either the user name or password is wrong. The "login denied" error is displayed only if the server you are trying to connect to sends this error code.

same problem with 1and1

== Info: Hostname was NOT found in DNS cache
== Info: Trying
== Info: Connected to avaricum.net ( port 22 (#4)
== Info: SSH MD5 fingerprint: 34470fe91ac2eb56ebcc58593a0280b6
== Info: SSH authentication methods available: publickey,password
== Info: Authentication failure
== Info: Closing connection 4

I had same problem.

I’ll leave the information for someone who might have same issue in the future.

First,  I tried to connect my server by other app (like FTP manager) and made sure all the setting information is correct. (Host, User, pw, etc) Then I realized that the setting to connect my server was correct.

So I went back to Textastic and deleted the current setting and set a new connection with the correct setting information. That made me connect to the server successfully!

I think it’s really beginner problem but wishing above information will be someone’s help.

Hi. I have exact the same issue. I checked the log, and it says that user name and public key do not match. However, I use the exact same data with Termius with no issue. I'd suggest you take a look.