0

FTPS - SSL connect error

Milan 7 years ago in iPad updated 7 years ago 8

Hi,


I am not able to connect to any of my FTP servers using FTPS (port 21 on one server and 990 on the second one).

For both connections I get  "Transfer Error: SSL connect error".


In the log I can see: 


== Info: SSL connect error

== Info: About to connect() to ftp.hereisdomain.com port 990 (#0)

== Info: Trying HERE-IS-IP...

== Info: connected

== Info: Connected to ftp.hereisdomain.com (HERE-IS-IP) port 990 (#0)

== Info: SSLv3, TLS handshake, Client hello (1):

=> Send SSL data, 0000000332 bytes (0x0000014c)

0000: ...omitted

0040: j.9omitted

0080: ....omitted

00c0: .....................ftp.heredomain.com...........4.2.................

0100: ....................................". .........................

0140: ............

== Info: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

== Info: Closing connection #0

== Info: SSL connect error


Can you please give me some hints?


Thanks,

Milan

PS: Thanks for the app. I am really excited about the capabilities of Textastic for iPad, the additional row is great and I wish to have it in other applications too :-).


Did you try to use FTPS (FTP over SSL) on port 21 instead?


You could also try to select a different "SSL Mode" setting. Maybe the server only encrypts the control channel and not the data channel.

Yes, I am trying FTPS (FTP over SSL) on port 21 on one server, where it is described to do so. I tried 990 and 21 as well on the other one (where I was told, that both 21 and 990 should work with FTPS - FTP over TLS).


I tried all 3 SSL Modes right now and I still get the same message.

-1

I've found the error from your log on this website: http://blog.techstacks.com/2010/03/3-common-causes-of-unknown-ssl-protocol-errors-with-curl.html


Some ISP's and DNS providers like to intercept your failed DNS queries in order to redirect you to a search engine results-style page offering you alternative URLs or "Did you mean...?" counter-query results. If you see an error like this: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol, it could be due to you typing the hostname incorrectly or the hostname is not yet tabled in your DNS. You can verify that with a simple "host" or "nslookup".

Could this be the problem in your case?

No idea. I am connected through a mobile connection now. I will try it at home on ADSL again where I am able to connect to those FTP servers from my desktop computer if there will be any difference. Thanks so far for quick responses.

Hi again. I tried it at home. Both servers work in TotalCommander. But I get still the same error on iPad in Textastic even if I am in the same network (using the same ISP)... Both servers are accessible from "FTP 4U" app on my ipad using SSL. In Textastic only FTP (without SSL) works.

SOLVED. It works now. 


Following works: instead of trying "FTPS (FTP over SSL)" with port 21 or 990, I had to use "FTPES (FTP over Explicit AUTH SSL)". I can use it with SSL Mode: "Require SSL for all communication" and I have I have to use Connection mode: "Passive (PASV)" otherwise I get "FTP: command PORT failed".


Many thanks Alexander for your time and special kudos to Wikipedia for teaching me about FTPES ;-)

It's great to hear that it's working for you now. Since I saw port 990 in the log, I thought you were already using FTPES. 

I changed that port manually :), I completely missed the FTPES option... Sorry for confusion.