0
Under review

Strange auto-indent behavior after paste

Dan 1 month ago in iPad updated by Alexander Blach (Developer) 1 month ago 2

I don’t know if it’s the language I’m using but if I have some code (soft indents)

if something

    Xyz

endif   


When I select the Xyz (cmd-left, shift-down), copy (Cmd-C), and paste it before the endif (down, up. Cmd-V) the code ends up looking like

if something

    Xyz

    Xyz

    endif

Is there any way to turn off auto-indent on paste?  This only happens if the end-of-line is selected which is really what I want and is easier to do rather than a shift-down, shift-left, Cmd-C, right, Cmd-V, return.