0
Answered

My HTML is not linking to my CSS

Tom Boyce 8 years ago in iPad updated by orca498 6 years ago 9

My HTML is not linking to my CSS for some reason. I have them in the same folder, and have put <link rel="stylesheet" type="text/css" href="style.css"/> and have named the css file style.css, but when I preview the html the css is not showing up

This should work. Can you send me both files to support@textasticapp.com?
I'm having the same issue here. Did you figure out why they won't link? 

Thanks,
+1
Under review
What does your html file look like?

This is a snap of the html file:

<!DOCTYPE HTML>
<html>
<head>
<meta charset="utf-8">
<link rel="stylesheet" href="screen.css" type="text/css" />
<title>CV Page</title>
</head>
<body>
<div id="Header">
<img src="" />
<p>this is the header</p>
</div>

and this is a snap of my css file:

#Header {
color: red;
font-weight: bold;
}

This does work for me. Is your css file called "screen.css" and in the same directory as the html file? File names are case sensitive in iOS, so something like "Screen.css" won't work!
Here are two screenshots of how it looks on my device:



If you have files in directories on your server then you need to create the same directory structure locally.  I have my CSS in a css folder on the server, but I just had the html and css files in the same place on my iPad.  I couldn't get the preview to show any of the formatting.  Then this post made me realize, so I created a css folder and moved the css files into it.  Now I can preview my changes before putting them up on the server.  I'm sure that you could download your images as well if you needed to be able to preview a complete page.  Maybe a piece could be added to the manual about mirroring your directory structure locally?
+1
Thanks, You directed me to the issue. 

I thought that by setting the file  "syntac definition" to "css" it will automatically set the file to be .css

so my file was named screen and when I changed it to screen.css it worked! 

Thanks so much Boss