0

Textastic for Mac is not saving preferences

Dariusz Owczarek 6 years ago updated by Alexander Blach (Developer) 6 years ago 18

Textastic for Mac is not saving preferences.

It works on one of my machines, but not on the other.

I've tried to remove preference files, application, but it haven't helped.

I've recently had a another customer with a similar problem.


In his case it helped to do this:


- Quit Textastic

- Delete the following folder: ~/Library/Containers/com.textasticapp.textastic-mac

- Restart Textastic


I'm not sure what's causing these problems. Did you have the Trial version installed before downloading the app from the App Store?

I have already tried deleting the ~/Library/Containers/com.textasticapp.textastic-mac folder, but it didn't help.


On this computer I didn't installed trial version before.


How can I check what's causing this?

Is there something logged in the "Console" app when you run Textastic?

Nov 28 14:25:57 sg0893951mm com.apple.appkit.xpc.openAndSavePanelService[46691]: assertion failed: 13A603: liblaunch.dylib + 25164 [FCBF0A02-0B06-3F97-9248-5062A9DEB32C]: 0x25

Nov 28 14:25:57 --- last message repeated 1 time ---

Nov 28 14:25:57 sg0893951mm.local com.apple.appkit.xpc.openAndSavePanelService[46691]: Bogus event received by listener connection:

<error: 0x7fff71117b50> { count = 1, contents =

"XPCErrorDescription" => <string: 0x7fff71117e60> { length = 18, contents = "Connection invalid" }

}


And here is the console entry when I'm exiting Textastic:

Nov 28 14:27:14 sg0893951mm.local Textastic[46686]: view service marshal for <NSRemoteView: 0x7f9419d04770> failed to forget accessibility connection due to Error Domain=NSCocoaErrorDomain Code=4099 "Couldn’t communicate with a helper application." (The connection was invalidated from this process.) UserInfo=0x608000273840 {NSDebugDescription=The connection was invalidated from this process.}

timestamp: 14:27:14.060 Thursday 28 November 2013

process/thread/queue: Textastic (46686) / 0x10d087000 / com.apple.NSXPCConnection.user.endpoint

code: line 2940 of /SourceCache/ViewBridge/ViewBridge-46/NSRemoteView.m in __57-[NSRemoteView viewServiceMarshalProxy:withErrorHandler:]_block_invoke

domain: communications-failure


Hrmm, that seems to be caused by the open panel. It shouldn't cause a problem with the app preferences.


Did you already try a restart of the machine? Maybe a service isn't working properly.


It also can't hurt to try to repair permissions in Disk Utility. Maybe a permission is wrong so it's not possible to write to a file.


I have to admit that those suggestions are just a shot in the dark :(

Correction: the second entry happens when I'm closing the file open window and the app is quitting right after.

Can you please try that:


- open a new untitled document with Cmd-N

- change some preferences

- quit the app with Cmd-Q while the document is still open

- reopen the app

- open preferences


Did it save the preferences?

I have an idea what might cause the problem. I added support for automatic termination and sudden termination in the latest update and this might be responsible for it.


Which version of OS X are you running and what kind of machine is this?

Tried the sequence you mentioned before and the preferences were not saved.

I'm running Maverics on Late 2012 MacMini w/o SSD. As far as I remember I had those issue even before Maverics. All works fine on 2011 MacBook Air.

I've also done repair permissions in Disk Utility.

Unfortunately, I'm running out of ideas. Since this sequence didn't work either, I think it can't be an issue with automatic termination...


I'm not sure what might be different on this machine.


The preferences should be saved in this file:


~/Library/Containers/com.textasticapp.textastic-mac/Data/Library/Preferences/com.textasticapp.textastic-mac.plist

Does this file exist?

It doesn't, here are the files from this directory:

com.apple.AddressBook.plist

com.apple.HIToolbox.plist

com.apple.LaunchServices.plist

com.apple.MultitouchSupport.plist

com.apple.ServicesMenu.Services.plist

com.apple.avfoundation.plist

com.apple.cmio.plist

com.apple.coremedia.plist

com.apple.coremediaio.support.plist

com.apple.corevideo.plist

com.apple.driver.AppleBluetoothMultitouch.mouse.plist

com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

com.apple.driver.AppleHIDMouse.plist

com.apple.inputmethodkit.plist

com.apple.opengl.plist

com.apple.security.plist

com.apple.security_common.plist

com.apple.speech.synthesis.general.prefs.plist

com.apple.speech.voice.prefs.plist

com.apple.symbolichotkeys.plist

com.apple.systemsound.plist

com.apple.universalaccess.plist

com.nvidia.OpenGL.plist

com.textasticapp.textastic-mac.LSSharedFileList.plist

org.cups.PrintingPrefs.plist

pbs.plist

Ok, I've created an (almost) empty file which you can download here: http://www.textasticapp.com/other/com.textasticapp.textastic-mac.plist.zip


Can you try to unzip the file and put it into this directory?


It should grow in size when you start Textastic, change preferences and quit the app.

It seems that preferences are saved properly now, but not the list of last opened files. Maybe I need to put another file there.


BTW, is the following expected?


sg0893951mm:Preferences darek$ pwd

/Users/darek/Library/Containers/com.textasticapp.textastic-mac/Data/Library/Preferences


Preferences darek$ ll

total 216

lrwxr-xr-x  1 darek  staff   54 28 lis 14:46 com.apple.AddressBook.plist -> ../../../../../Preferences/com.apple.AddressBook.plist

lrwxr-xr-x  1 darek  staff   52 28 lis 14:46 com.apple.HIToolbox.plist -> ../../../../../Preferences/com.apple.HIToolbox.plist

lrwxr-xr-x  1 darek  staff   57 28 lis 14:46 com.apple.LaunchServices.plist -> ../../../../../Preferences/com.apple.LaunchServices.plist

...

Interesting. It seems like Textastic wasn't able to create the file itself. Maybe there is an issue with the sandboxing system on your machine.


Since this is the sandbox container that is only visible to the app, it is normal that those files are just links to the original files.


The list of recent files should be saved in the file "com.textasticapp.textastic-mac.LSSharedFileList.plist" that is in the same directory.

...

rwxr-xr-x  1 darek  staff   80 29 mar  2013 com.textasticapp.textastic-mac.LSSharedFileList.plist -> ../../../../../Preferences/com.textasticapp.textastic-mac.LSSharedFileList.plist

-rw-------  1 darek  staff  650 29 lis 17:22 com.textasticapp.textastic-mac.plist

...


Is it ok?

Here is how it looks over here:


lrwxr-xr-x   1 lextar  staff    80  8 Sep 19:19 com.textasticapp.textastic-mac.LSSharedFileList.plist -> ../../../../../Preferences/com.textasticapp.textastic-mac.LSSharedFileList.plist

-rw-------   1 lextar  staff   910 29 Nov 19:46 com.textasticapp.textastic-mac.plist


So this does look fine.