0
Fixed

File extension and highlighter

Karsten Becker 8 years ago updated by Alexander Blach (Developer) 8 years ago 3

Hi,

It appears that Textastic for Mac is not treating permissions correctly or something. When I use Forklift to edit files on my server, it copies them to a local directory like: ~/Library/Caches/com.binarynights.ForkLift2/#0/monitrc


With Textwrangler I can edit and save this file just fine, but Textastic give me a warning. From looking at the log I found that it says: 

25.03.13 15:14:53,589 sandboxd[1576]: ([1304]) Textastic(1304) deny file-write-create /Users/karstenbecker/Library/Caches/com.binarynights.ForkLift2/#0/monitrc.ini

which I guess is caused by the fact that I changed the highlighting to INI.. 


If I don't change the highlighter, I can save it just fine..


Please don't add any extension simply based on the highlighter..

Thanks :)

Thanks. Another user recently reported a similar error. Do you have Auto Save enabled or disabled? (see http://osxdaily.com/2012/08/22/turn-off-auto-save-os-x/)

Nevermind - I changed the behavior so that this now only happens when the document is a draft/untitled document and not saved yet.


It will be fixed in the next update.

It is enabled, but now disabled :D Always wondered if you could turn it off ;)

Doesn't change the problem though...