+1

Auto set scripts to executable?

Michael Savich 7 years ago updated by Alice Bevan-McGregor 7 years ago 6

I saved a script to Finder and tried to run it, but I got a permission denied error. Seems there was no write access allowed. Is this a bug? 

Which exact error message did you get?


There was a bug that quarantined executable files, but it was fixed in version 2.0.

-bash: /Users/michaelsavich/Documents/Ni.py: Permission denied


After that, I can get it to run using chmod.

Well, the executable bit isn't set automatically. You need to set it using chmod.


If you run "python /Users/michaelsavich/Documents/Ni.py" instead it should work.


I don't consider this a bug.

Ok. It's standard behavior in Text wrangler, but I can see why you wouldn't want your app to auto-create executables. Also: did I mark this as a bug? I didn't think I did, sorry.

I just tried to answer your question "Is this a bug?" ;)

As a quick note and test, once the executable bit is set Textastic preserves it upon subsequent saves with Apple live-save disabled; likely with it enabled as well.  Not all programmers' editors get that right. :D