0

WEBDAV - question about changing directories

mhmedia 8 years ago updated 8 years ago 2

I have a webdav area on my web server that contains a number of directories. When I connect I can see my directories as 0-byte files, so I cannot change to those directories. The permissions are 0770/drwxrwx---  and are owned by the web server. If I use the Keynote app to access the same webdav directories there is no problem.  Is this a bug, feature, or my mistake?  Tnx!

This seems to be problem in how Textastic interprets the response of the PROPFIND http request. It should show up as directories, not as 0-byte files.


Which WebDAV server do you use?

Hi.. I'm using the webdav module that's included in the lighttpd server, running on Linux. Here's the server log for the Textastic access: the "401" is caused by the basic authentication:

xxx.xxx.xxx.xxx:80 - - [01/Sep/2011:15:26:48 +0100] "PROPFIND /DAV/ HTTP/1.1" 401 351 "-" "Textastic/34 CFNetwork/485.13.9 Darwin/11.0.0" "-"
xxx.xxx.xxx.xxx:80 - myuser  [01/Sep/2011:15:26:49 +0100] "PROPFIND /DAV/ HTTP/1.1" 207 387 "-" "Textastic/34 CFNetwork/485.13.9 Darwin/11.0.0" "-"

and here's Keynote accessing the same area:

xxx.xxx.xxx.xxx:80 - - [01/Sep/2011:15:30:15 +0100] "PROPFIND /DAV HTTP/1.1" 207 670 "-" "iWorkHTTPKit (iPad; iPhone OS 4.3.5; en_GB) Keynote/336" "-"
xxx.xxx.xxx.xxx:80 - - [01/Sep/2011:15:30:17 +0100] "PROPFIND /DAV HTTP/1.1" 207 1731 "-" "iWorkHTTPKit (iPad; iPhone OS 4.3.5; en_GB) Keynote/336" "-"
xxx.xxx.xxx.xxx:80 - - [01/Sep/2011:15:30:36 +0100] "PROPFIND /DAV/myuser HTTP/1.1" 401 351 "-" "iWorkHTTPKit (iPad; iPhone OS 4.3.5; en_GB) Keynote/336" "-"
xxx.xxx.xxx.xxx:80 - myuser [01/Sep/2011:15:30:39 +0100] "PROPFIND /DAV/myuser HTTP/1.1" 207 2931 "-" "iWorkHTTPKit (iPad; iPhone OS 4.3.5; en_GB) Keynote/336" "-"