+1

Informix-4GL

Anton Zujev 9 years ago updated by mohammed yaazdani 7 years ago 5
Please add support for rare languages, namely Informix-4GL. I work with it and the support would be a great feature. At least add support for custom syntax highlighting schemas.
Here's the 4GL syntax file from a notepad called jEdit. It contains all keywords, operators and stuff in an xml-file. If that could be of any help.

I'm currently working on a new syntax highlighter for Textastic 3.0 that will allow you to add custom syntax definitions.
Great! Thanks for the news!

in 4gl i am calling a unix script:

LET string = "mailx -s ' ",lc_hosp ,lc_hospname ," Has Updated TCU ' abcd@efl.com < ",mc_report
RUN string

problem occur when lc_hospname have any special symbol, for example :

lc_hosp = " children's hospital of united state "

when program try to run the string error is "unmatched ' "   (  ' is coming from children's)

can not change the name of hospital. need to mail hospital name as it is.


Dear All,


May God bless you, Hope you all are in good health, My name is Mohammed, Our team of Gazzaz  is working on this issue since a week with no success. I hope by the god's grace may get the solution here, I tried to contact IBM but the solution provided did not served our purpose unfortunately.


Issue:-

Please allow me to explain what happened that last week, one of our site’s server in KSA crashed, which was running since 15 years on a  “Proliant 6000 server”, We rebuilt and recovered all our data and applications and by the grace of god its operational now on optiplex machine, This errors were started when our team of 4gl programmers test compilation of their existing programs with “i4gl”(GUI based to compile forms) and “c4gl”(TEXT based to compile forms)  utilities tools.



Meaning of this Error after googling but still confused about solution:-

-4604  Errors found in 4GL module.
Select the Correct menu choice. You will be shown the module source with error messages included.

We trigger i4gl to compile text forms we follow steps below and it’s a GUI as us could see in Screen shot above :-

• #Su – Informix
• $i4gl
• On “Module” and hit enter
• Select “Modify” and hit enter
• Select a Program and hit enter
• Select Compile
• Select Runnable
• It says Correct errors in the 4GL module and give the above error


Output:-

Error:- 4604: Error(s) found in 4GL module

Our  Workaround to resolve above Error:-

We contacted IBM, since we thought it is related with 4GL and they suggested to compile programs with “c4gl” utility

You may check this IBM forum for your reference where we raised a tickethttps://www.ibm.com/developerworks/forums/thread.jspa?messageID=14885315&#14885315

When we trigger c4gl to compile text forms am following steps below :-

• #Su – Informix
• c4gl source.4gl -o filename.4ge


Output:-

Error:- c4gl427: cc: not found


Our Workaround to resolve above Errors:-

After realizing that it’s an SCO Optimizing C Compiler which is needed, I tried to install the following below from the licensed SCO CD and it did installed coz I choose “Defer” already which is 60 days buffer, unfortunately we missed  license Number, License Code, License Data which we missed. In fact we have all the original CD’s and license agreement on the below products


·  SCO Open Server Development System(ver 5.1.1A) (require license but using as a defer after khobar server crashed)

·  SCO Optimizing C Compiler (ver 2.1.4d) (doesn’t require license)

After above installations errors still persists however when compiling forms with “c4gl” utility it  warned by this new error"acomp: Warning-Product is not licensed" 

I have checked the following directories and recompiled the program however results the same as before

·  /opt/K/SCO/unixds  “yes it’s there” 

·  /usr/ccs/bin/cc   “Yes it’s there” 

·  /usr/bin/cc  “Yes its link on this location here” 

If the C compiler is placed on its location, that means its working perfectly, isn’t it?,  Then why we are unable to compile the program?


For your Additional information, below are the parameters set in .profile of Informix user

• #Su – Informix
• $vi .profile
• export INFORMIXDIR=/usr/informix
export INFORMIXSERVER=khobar
export INFORMIXSQLHOSTS=/usr/informix/etc/sqlhosts
export INFORMIXBIN=/usr/informix/bin
export PATH=/bin:/usr/bin:/usr/sbin:/usr/ccs/bin:$PATH
export LD_LIBRARY_PATH=$INFORMIXDIR/lib:$INFORMIXDIR/lib/esql:$INFORMIXDIR/lib/tools (as am using KSH shell)


We Require your help as early as possible.


Conclusion:-

Since now it’s clear that it’s not an compiler issue at SCO unix level, It could be 4gl.  If  it’s an License issue then I have to contact Informix,  need your suggestion and advice, Waiting for your reply.


Thank You 


Kind Regards,

Mohammed Kaleem Yazdani