0
Under review

Stop auto-adding period when double-spacing

david.allie 2 years ago in General updated by ajcullum 3 weeks ago 5

Aside from using Textastic for coding, I like to use it for keeping .txt files for simple notes. I’ve noticed that whenever I (on purpose) enter two or more spaces (e.g. to create a simple column table), a period is auto-added in the the first position of two spaces. This is annoying... seems more appropriate to a word processor than a code/text editor... and I wish there was a setting/preference to allow me to enable/disable this action.

Hello, you can change this by disabling the following setting in your device's settings:

General -> Keyboard -> "." Shortcut

Thank you, Alexander, for the VERY quick reply. That works perfectly for my needs. Thanks again!

This thread might be too old now to get a response, but:

I also would rather not have the auto-addition of a period in Textastic, but I do want it to continue to work everywhere else, so I'd rather not turn it off at the system level. Could we have a toggle for this functionality in Textastic's settings, like we do for other iOS functions like auto-capitalization, auto-correction and smart punctuation? I'm actually surprised this wasn't already in that list.


Thanks for your consideration!

Under review

While the other settings can be configured per text field/text view, the "." shortcut is a global setting unfortunately. AFAIK there is no way to disable it only in one app since this is handled by the iOS text system.

Alas. Thanks anyway!