Under review

Document picker error

maurizio manuguerra 9 years ago in General updated by Alexander Blach (Developer) 9 years ago 3
This is driving me crazy.
On my IPad Air, I edit files on a server using the document picker and Transmit (sftp connection). So far so good.
I have a second iPad where the same workflow doesn't work: I select the "Open.." Menu, then Transmit as file provider, the connection is established, I can browse the files on my server but when I want to open one (whatever the extension) I get the message "The plug-in returned an error. Could not connect to server xxx." Please note that the server detail are the same on both iPads as they are synced with Panic sync service.
Beyond the fact that an identical workflow works on the iPad Air (same versions of everything), the crazy part is that:
1. If I use a different file provider, e.g. Working Copy, it works
2. If I use a different text editor, e.g. Koder, it works.
3. If I offer the file to Textastic from Transmit, it works.

Of course I have tried to reboot the iPad, uninstall/install both apps, with no effect.
I also tried the same workflow on the iPhone: it doesn't work as well.

Has anyone any idea of what is going on? I found no info search for this problem on the web.

I'm experiencing the same problem.. I bought Textastic & Transmit exactly because of the document picker integration but unfortunately can't use them together...
I'm pretty sure this is a bug in Transmit, considering this tweet by Panic Inc: