Love your App, thank you! I have one quibble, actually a bug with TextExpander/Textastic

dmahaffy 13 years ago updated by Alexander Blach (Developer) 13 years ago 4

I have a snippet that crashes Textastic 100% of the time when triggered. It is a simple time-stamp:

 %@-1h%1I:%M %p

That should render this: (a space) 1:45 PM

I normally use "t" and then hit "space" to trigger it. What happens is that I hit "space" and Textastic registers the space, the space on the keypad stays pressed, then the app quits.

In other TextExpander apps, this is no problem. In fact, I've got that same snippet embedded in another snippet and it works fine. But to enter a simple time stamp = crash.

Any thoughts? Thanks...

[EDIT: I should note that I've tried changing the trigger from "t" to "time", etc., all attempts still result in an app crash]


thanks for reporting this. I just added this snippet to TextExpander and it crashes for me, too.

I will try to find out what the problem is.

This seems to be a problem in TextExpander. I tried your snippet in two other popular apps: PlainText and Nebulous Notes. Both apps also crashed.

I'll forward this issue to the TextExpander developers.
I'm glad you were able to test it and pass it on to their dev team.

Hope to see a fix soon! Curious as to why it would work embedded into a snippet like this:


<A HREF=""></A> %@-1h%1I:%M %p


But not "stand alone"

Well, unfortunately I don't know because I can't look at their source code. The debugger says that it's trying to find a string at character position "-5" when it crashes.

So, if the snippet is included in a larger snippet, the character position -5 actually exists. But this is just speculation on my part.