+5
Under review

Git repository on WebDAV volume

ProfesseurB 10 years ago updated by Alexander Blach (Developer) 7 years ago 6
In order to manage code editing and synchronization of my iPad, I tried to install a Git repo on the Textastic folder, when mounted on my Mac through WebDAV. It works pretty well, but still there are difficulties. In particular, it keeps on saying:
"Unable to create '/Volumes/10.0.1.9/.../.git/index.lock': File exists.". Any idea?
Can you please tell me the steps I need to follow to reproduce the problem? Unfortunately, I use Subversion myself so I'm not familiar with Git, sorry.
+2
Okay, if you have git install, you might try this. It just creates an empty repo. So, my pwd is /Volumes/10.0.1.9. Here are my commands:

mkdir test
cd test
git init

And it succeeds to create the repo, but with errors messages:

error: could not lock config file /Volumes/10.0.1.9/test/.git/config: File exists
error: could not lock config file /Volumes/10.0.1.9/test/.git/config: File exists
error: could not lock config file /Volumes/10.0.1.9/test/.git/config: File exists
error: could not lock config file /Volumes/10.0.1.9/test/.git/config: File exists
Initialized empty Git repository in /Volumes/10.0.1.9/test/.git/

More generally, this prevents Git from working "smoothly" (and my Git graphical interface, Tower, really worries about those messages).
Thanks! I'll try to find the cause for this behaviour.
Any solutions found?
Just had the same idea. Directly checking out a GIT repo on the mounted webdav volume would be awesome.
+1

Agreed, this would be a useful intermediate step to supporting version control until full support is available. This might also be much easier to implement. Right now I'm using ownCloud (similar to dropbox) to sync files through webdav and then remotely executing git commits through SSH on my home machine. Not super elegant, but it works.


Also, thanks very much for putting this editor together. I tried using the Vim port, and had so many problems it just wasn't worth the effort. I've been using your editor for a few weeks and I've quit carrying my laptop with me any longer. The more I use it the more I like it.