+2

Keeps crashing in FTP....

Pdaml 9 years ago updated by Jccc 8 years ago 6
When trying to download files using FTP, the app keeps crashing. Tried repeatedly. Total files in folders is about 400.
Sorry, but I need a lot more information in order to find out why it would crash:

When exactly does the crash happen? When retrieving the file information? When downloading files? When downloading a particular file?

Since 400 files is quite a lot (although this has been tested with a lot more files), this could possibly be an issue with low memory: did you try to restart your device before attempting the download?

Did you try to download only part of the files/folders and not all of the 400 files? Did it work?

Can you download other files/folders on the same server? If not: which ftp server software is it running?
It also doesn't work for me with large directory/file structures. I've tried to download "app" folder from Magento ecommerce application, which is quite big (more than 100 folders in it). When tapping Download button Textastic starts to enumerate files and folders and displaying it, the counter goes to about 100 folders and few files and then it crashes. I've also tried to download only a subdirectory of this folder, which also crashed the app :(.
Hi, I've just recently discovered a bug that will be fixed in the next update.

Please try to limit the amount of concurrent connections to 1 (default is 3) in the FTP configuration screen. There's currently a bug that results in a crash when directory listings are parsed in several concurrent threads.
Great! I had this issue as well but couldn't relate to a given number of files or folders as it would sometimes blow up with less files/folders than at other times with more stuff...
BTW and while I'm here, your comment form (or font) looks awfull in my iPad! Can u please change to a better font here?
Just bought the app and have this issue. Im trying download via SSH from OSX Lion default ssh server.
Limiting the amount of current connections to 1 (the default is 3) in the connection's setting fix this issue for me.