0
Fixed
btxtic 3 months ago in iPad • updated by Alexander Blach (Developer) 2 months ago 4

I just got the app to do quick edits on a website. I have had no luck being able to connect with SSH. I have the correct settings (host, user, password) because I am back to using PuTTY.


From log

== Info: Hostname was found in DNS cache
== Info: Trying ..88.231...
== Info: Connected to ....com (....88.231) port 22 (#2)
== Info: Failure establishing ssh session
== Info: Closing connection 2
Both the iPad and pc are connected to the Internet through the same wifi access poin
GOOD, I'M SATISFIED
Satisfaction mark by btxtic 2 months ago
Under review

I recently had another user report a similar problem. In their case, the hosting provider changed their ssh server settings to limit the number of supported ciphers. I guess that's the case here as well. I'm currently investigating which ciphers Textastic needs to support to solve this problem.

It would be helpful to know which hosting provider you are using and which host name you are trying to connect to.

If you don't want to share this information publicly, please send it to support@textasticapp.com, thanks!

The problem has been fixed in the new textastic version released.


It seems my host provider began blocking the old questionable ssh ciphers that the app was using to connect, and that is why I could not connect. I am was told that textastic was updated to have latest ssh support.

Fixed

Yes, exactly. Textastic 6.3.1 uses the latest version of libssh2 which supports more ciphers.