0
Under review
textastic 4 months ago in General • updated by Alexander Blach (Developer) 4 months ago 4

I have emacs in my manual reflexes. The emmet use of Ctrl-A and Ctrl-E means I can't use those emacs actions now. I don't use emmet, so could there be a setting to completely turn off emmet so it doesn't interfere with those keystrokes? Thanks

In preferences just add some new shortcut for these emmet commands : emacs standard will be active after that.

You are right, the standard Emmet keyboard shortcuts conflict with emacs commands.

As a workaround (as suggested by MrMen), you can go to your Mac's System Preferences -> Keyboard -> Shortcuts -> App Shortcuts and override the standard shortcuts for those two commands with other shortcuts. Here are screenshots of how this might look:





If you do this, you can use ctrl+a and ctrl+e as you are used to.

Thanks for the help - but my problem is on my iPad and my iPhone, not on my Mac. I've searched, but I can't seem to find any way to change keyboard shortcuts on iOS unless the app itself suppports it. Any ideas? And I'd still request a way to turn off emmet completely for those of us who don't want/need it at all (recognizing how great it is for those who use it!)

Under review

Oh, sorry for that. As far as I know there currently isn't a similar solution on iOS. I'll consider adding an option to change or disable the Emmet shortcuts.