Textastic is a text, code and markup editor for iPad and iPhone with rich support for syntax highlighting, FTP, SFTP and Dropbox. It will continue to be actively developed to provide you with the features you need to get your work done.

In order to achieve this, we would appreciate any and all feedback on challenges encountered when using Textastic.

Please also have a look at the manual.

Be sure to vote for the features you want to see implemented!
Jim Stoker 7 years ago 0
It would be nice to have syntax support for Cisco IOS and simlar languages for those of us who are network admins.
Clarence 6 years ago • updated by Alexander Blach (Developer) 6 years ago 4
The "tab" reminds on screen even when additional keys are hidden.

Textastic is of latest version on original iPad with iOS 5.0. Same problem exists no matter in landscape or portrait orientation, split or docked keyboard.

screen: http://d.pr/fixs
Fixed for Textastic 3.1
Markus Ziegler 6 years ago • updated 6 years ago 4
I am using and liking the app for some time now.
I wanted to connect to my xampp server at home in my macbookpro.
Downloading the files did work. But whenever I upload a file it says something about not working 'upload failed (at start/before it took off)'
What is this?
With my ftp server on my domain all works ok, but I wanted to not always have to upload via the internet...
Any Ideas?

Adam Acosta 5 years ago in iPad • updated by Alexander Blach (Developer) 4 years ago 3

I've copied a bunch of javascipt (Backbone.js) in Safari (from raw view in Github) but when i press and hold in Textasic, paste is not an option.

Other than that, is there a better workflow for grabbing libraries and adding them into textastic? I can't seem to find a good clean way of just simply grabbing js files from anywhere and get them into textastic.

Admiral27 6 years ago • updated by Joseph Wilcock 6 years ago 2
When I write out text from the screen keyboard, ever third character causes a 10 sec delay when everything freezes, but then spits out the whole buffer. It's very hard to code with this problem. I turned off everything I could, but it still happens.
Not a bug
Jeremy Ricketts 5 years ago • updated by Alexander Blach (Developer) 5 years ago 3
On OSX, I tried copying my id_rsa into /ssh within Textastic. I left everything else default. I tried entering my username. I tried entering my server password even though this RSA key doesn't use one. I tried importing my id_rsa.pub instead, but that didn't work. I keep getting "Transfer Error. Wrong passphrase or invalid/unrecognized private key file."

I know this id_rsa works because I use it to SSH into my server via terminal, Transmit FTP, and other applications. Lastly, I tried using some of the other files in my ~/.ssl folder on OSX. Oh, and I also tries using my server's FQDN instead of the IP.

Still get the same message! Any thoughts?
KevinMc 6 years ago • updated by Alexander Blach (Developer) 6 years ago 1
When I attempt to "Open in..." and select "Pages", the Pages program opens to it's "My Documents" screen, but the file being edited in Textastic never shows up.
Under review
freeranger 2 years ago in iPhone • updated by Alexander Blach (Developer) 2 years ago 1


It would be great if you could with one click get back to the file you currently have open - once you gone into the menu system, say from a OneDrive file I have opened, there is no way to quickly go back to the file apart from navigating to "recent files" or back to the original location - it would be nice to have a single click to "close the menu" and return to the file

stargate 7 years ago • updated by Alexander Blach (Developer) 7 years ago 0
I would like to see an option for turning off syntax highlighting, to make the editor run at top speed for editing plain TXT files.
This options already exists: just open the File Properties popover and choose the first entry "Plain Text" as the syntax definition for this file.

This disables syntax highlighting.
iSee 5 years ago 0
It would be nice, if you could add a mode of editing like in SubEthaEdit. As far as i know, they use an open protocol.